exacqVvision Enterprise Health Manager User Manual

Introduction

exacqgVision Enterprise Health Manager (eVEHM) allows you to remotely monitor certain parameters
and events on exacqVision Servers with Enterprise licenses. eVEHM is a Client/Server application. The
eVEHM Server runs as a service on any computer with a network connection to the monitored
exacqVision Servers and a database connection. The eVEHM Client only requires connectivity to the
database. eVEHM can run as part of a multi-user platform connected to a MySQL or Microsoft SQL (MS
SQL) database, or on a standalone Client/Server workstation using an SQLite database that is created by
the eVEHM Server.

The following diagram shows how eVEHM communicates with the database server and exacqVision
systems.

N

Database Server

eVEHM Client | | &VEHM Client

’

b -
~ ~

|
|
|
|
|
}
|
|
|
|
: eVEHM Server
- |
|
|
|
|
|
|
|
|
|
|
|

Multi-User Health Monitoring

exacgVision NVRs

eVEHM
SCLite Client

Standalore Health Monitor Workstation

NOTE: In the Multi-User example, eVEHM and the database can run on the same server.

NOTE: In the Standalone example, eVEHM, SQLite, and the eVEHM Client must all run on the same
workstation (even an exacqVision client computer). Clients from remote machines cannot connect to
the SQLite database in the standalone installation.
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The following drawing shows the approximate bandwidth used by the various eVEHM connections.
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Installation

NOTE: eVEHM Server can be installed on a Linux or Windows platform. eVEHM Client can be installed on
a Linux, Windows, or Mac platform. If eVEHM will connect to a new MySQL database, see Appendix A
before starting the procedure in this section.

To install Enterprise Health Monitor Client and Server, complete the following steps:

1. Runthe exacqgVisionHealthClientAndServer.exe file and follow the onscreen prompts.
When the database types appear, select the type as follows:

e MySQL (appropriate for most installations)
e ODBC (select only if the database type is MS SQL)
e SQLite (select if the eVEHM client will be run only on the eVEHM server)

3. Configure the eVEHM database connection to match your database. If eVEHM and the database
are located on the same server, enter 127.0.0.1 as the hostname, as shown in the following
example.

r N
¥ exacqVision Enterprise Health Manager Client and Server - 1.4.4.274... l = J &l

Coohows My 20/ Detabasie Convincion exacqvision
Specify details regarding the MySQL database to be accessed.

EnterpriseliiealthiVianager
Hostname: Port:

127.0.0.1 3306

Database Name:

exacgEVHM 1

Username:

root
Password:

[ < Back H Next > ] [ Cancel }

4. If eVEHM will connect to an existing SQL server, select Write Schema File and provide the file to
the database administrator for manual configuration. Otherwise, select the Update Database
Schema During Installation to have the installation process take care of this for you.
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eVEHM Client Overview

By default, eVEHM Client opens to the Active Events tab if the connection the database is successful.
Otherwise, you must select Open from the File menu and browse to the database.

You can open the following tabs from the View menu:

Unacked Events. This tab shows all active events that have not been acked.

Active Events. This tab shows all monitored events that are still in progress or haven’t been

resolved. This can include events that have been acknowledged (acked).

All Events. This tab shows all events regardless of whether they are active, inactive, acked, or

unacked.

Systems. This tab shows a list of all monitored servers and their status.

Options. This tab allows you to modify eVEHM parameters.

File Edit REEY

Unacked

Everk ID
10055
10057
10056
10055
10054
10053
1005z
10051
100s0
10049
1nnas

Refrash

Unacked Events
Active Events

Systems
Options

FS

12/13(2010 12:10:1..,
12/13(2010 12:10:0,.,
12{13(2010 12:07:0...
12{13/2010 12:06:5...
12/13(2010 12:02:1..,
12/13(2010 12:02:0..,

1200301 17002

ive Events

All Events ¢

werk End Time

Evert Type

Event Details

Description Address

Serial Murmber

2/132010 12:13:57 PM
232010 12:13:57 PM
_ZJ'ISJZEIUJ 12:11:40PM

__P/13{2010 12:11:40 PM

12/13(2010 12121114 PM
12/13(2010 12:21:14 PM
12/13/2010 12:08:34 PM
12/13/2010 12:08:34 PM
12/13(2010 12:06:23 PM

12/13(2010 1206123 PM
12HRIA 17001 .42 DM

Server Connection Error
Server Connection Error
Server Connection Errar
Server Connection Errar
Server Connection Errar
Server Connection Error
Server Connection Errar
Server Connection Errar
Server Connection Errar
Server Connection Errar
- Fannar Finr Frver

System 192,168,100,21;22609 disconnected,
System 192.168.100.21: 22609 disconnected.
System 192.168.100.21:22609 disconnected.
System 192.168.100.21:22609 disconnected.
System 192,168,100,10:22609 disconnected,
System 192,168,100,10;22609 disconnected,
System 192.168.100.10:22609 disconnected.
System 192.168.100.10:22609 disconnected.

System 192,168,100,50:22609 had a receive Failure,
System 192,168,100,50:22609 had a receive Failure,

Suckam 187 142 100 2229600 dicrannarct Fad

exacgVision Panasonic Server
exacqVision Panasonic Server
exacqvision Panasonic Server
exacqvision Panasonic Server
exacqVision Linux Server
exacgVision Linux Server
exacqvision Linux Server
exacqvision Linux Server
exacqVision Arecont Server
exacqVision Arecont Server

avaratlicinn &CTi Saruar

192.,163,100.21
192.163.100.21
192.165.100.21
192.168.100.21
192,163,100.10
192,163,100.10
192.168.100.10
192.165.100.10
192,163,100,50
192,163,100,50
107 162 100 77

ERD&35001209
ERD&35001209
ERDG35001209
ERDB35001209
LinuzHybrid
LinusHybrid
LinuzHybrid
LinuzHybrid
00-19-D1-E2-12-92
00-19-D1-E2-12-92
ARt RS AR

To close a tab, click on the X next to the tab’s title. You can open multiple tabs simultaneously. To view
more than one tab at a time, click and drag a tab title to an empty part of the screen. You can then
resize a tab as desired by clicking and dragging its borders.

Each tab is described in greater detail the following sections.

NOTE: Information on all eVEHM tabs is displayed in columns. To add or remove a column from a tab,
right-click any column title and select a column name (columns with check marks next to them are
displayed in the tab). You can also re-sort entries by clicking a column title.
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Adding Systems

The first thing you should do when you run eVEHM is add a server that you want to monitor. Open the
Systems tab and select Add System from the Edit menu to display the System Information pop-up
window. Enter a valid username as configured on the system, a password, the password again, the IP
address of the system, and the port number through which the system communicates on the network.
Click OK when finished.

Username: ,7
Passward: ,7
Canfirm: ’7
Address: ,7
Park: W

| Cancel |

When you select a line on the Systems tab, the Edit menu also contains an Edit System and a Delete
System menu item. You can use these to modify system information or remove a system from eVEHM
monitoring.

The Systems tab contains the following columns:

e System ID. This is a sequential number assigned to each server. The first system is 1, and each
successive server is the next available number. If a system is deleted from the list, all systems
maintain their original System ID.

e Address. The IP address of each server (not the address of an IP camera).

e Port. The port number through which the server communicates over the network.

e Username. The account through which the user is logged in to the server.

e Password. The password that the account used to log in to the server.

e System Name. The name of the server as it is identified on the network.

e Serial Number. The serial number of the system as assigned during manufacturing

e Status. The current status of eVEHM monitoring on the system.

File Edit View Help

Unacked Events Systems 3¢ | Active Events All Events

Swskem ID | Address | Port | s, | Password | Syskem Mame | Serial Murnber | Status
1 192.168,100,30 22609 jse,,, HREEEREE aescavision XIS Server 2003 00-16-76-A3-E1-66  Monitoring
z 192,168, 100,50 22609 jse.., CHEEREREE S geacgWision Arecont Server 00-19-D1-EZ-12-9Z  Monitoring
3 192.163,100,25 22609 jsg,,, EkEssRdk aes-avizion Sony Server 00-19-D1-81-19-47  Monitoring
4 192,165,100,40 22609 jse,,, ekkkkbs o apaqavision IQEve Server 00-19-D1-05-04-a0  Monitoring
5 192.168.100.10 22609 jse,., CHEEEEREE avacgWision Linux Server LinuxHybrid Monitoring
6 192,163, 100,21 22609 jse,,, HkeeERdk o aes-avision Panasonic Server  EROS35001209 Manitoring
7 192.168,100.22 22609 jse,,, HEEREREE S geacgiision D1 480 Server 00-30-45-94-3E-B1  Monitoring
g 192.168,100.23 22609 jsg,,, ChkEeERdk aeseavizion ACTI Server 00-1C-CO0-BS-6B-D1  Monitoring
11 192,168,100,34 22609 admin  ***EE% Dans Trunk Server 00-16-76-13-40-09  Monitoring
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Viewing and Managing Monitored Events
By default, the Active Events, Unacked Events, and All Events tabs contain the following columns:

e Event ID. This is a sequential number assigned to each event. The first event is 1, and each
successive event is the next available number.

e Event Start Time. This is the date and time of the start of the event.

e Event Type. See the “Options Tab” section of this document to see the types of events that can
be monitored.

e Event Details. This shows the camera affected by the event or the name of an activated trigger.

e Description. This is the server on which the event occurred.

The ActiveEvents and All Events tabs also include the following columns:

e Ack Timestamp. The time that the event was acked (if applicable).
e Ack Name. The name of the person or account that acked the event.
e Ack Comment. Any optional information about the ack.

File Edit Wew Help

Unacked Events Systems Active Events >

Event ID | Event Start Time Event Type | Event Details Description | Ack Timestamp ‘ Ack Mame | Ack Comment

8404 12/1/2010 9:57:50 AM IP Camera Mot Connected  Wh-NWS025 - 1,3M Cube exacqWision Panasonic Server

FOZ6 1212010 9:57:50 AM IF Camera Mot Connected  Wi-RMWS025 - 1,34 Cube exacgiision Panasonic Server

7878 12/1/2010 95750 AM IP Camera Mot Connected  Wy-NWS025 - 1,3M Cube exacqWision Panasonic Server

7809 12/1/2010 9:57:50 AM IP Camera Mot Connected  Wy-NWS025 - 1,3M Cube exacqWision Panasonic Server

7783 12/1/2010 9:57:50 AM IP Camera Mot Connected  Wh-NWS025 - 1,3M Cube exacqWision Panasonic Server

FF40 0 1212010 9:57:50 AM IF Camera Mot Connected  Wi-RMWS025 - 1,34 Cube exacqiision Panasonic Server  12(3/2010 41255 PM  MDG Testing Ack
FF0S  12/1/2010 95750 AM IP Camera Mot Connected  Wy-NWS025 - 1,3M Cube exacq¥ision Panasonic Server  12f3/2010 4:12:55PM  MDG Testing Ack
FF03 0 12/1/2010 9:57:50 AM IP Camera Mot Connected  Wy-NWS025 - 1,3M Cube exacqWision Panasonic Server  12/3/2010 4:12:55PM  MDG Testing Ack
FF02 12/1/2010 9:57:40 AM IP Camera Mot Connected  Wh-NWS025 - 1,3M Cube exacqWision Panasonic Server

9195 1212010 9:36:05 AM IF Camera Mot Connected  Toshiba PT7161 - Sales exacgiision Linux Server

8799 12/1/2010 9:36:05 AM  IP Camera Mot Connected  Toshiba PT7161 - Sales exacaision Linux Server

To ack an event, double-click its entry (or select Acknowledge Event from the Edit menu) to open the
Acknowledge Event window. Enter an identification and comment about the ack, and then click OK. To
modify an ack, double-click the event entry again (or select Edit Acknowledgement from the Edit menu)
and modify the information in the pop-up window. To delete an ack, highlight its entry and select Delete
Acknowledgement from the Edit menu.

Acknowledge Event @

System:  exacqYision Sony Server
Type: IP Camera Mot Connected
Details:  EX104 - E Main Entrance

Acknowledger:

Caormrment:

[0]'4 | Cancel |

NOTE: Acking an event does NOT remove it from the Active Events list; it simply means that the event
has been noted. The event is removed from the Active Events list only when it has an actual Event End

Time.
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The All Events tab also includes the following columns:

e Event End Time. The date and time of the end of the event.

e Address. The IP address of the server on which the event occurred.

File Edt View Help

Unacked Events Systems

Active Events

AllEvents ¢ | Options

E.. = | StartTime

‘ Event End Timne:

EventType_ID

‘ Event: Details

Description

Address

Serial Number

Ack Timestamp | Ack Mame

Ack!

9549 12/9/2010 3:28:52 PM
9548 12/1/2010 9:57:50 AM
9547 1205/2010 4:47:52 PM
9546 12/8/2010 4:54:17 PM
9545 12/5/2010 44734 PM
9544 12/8/2010 4:54:17 PM
9543 1292010 2:44:26 PM

9554 12/10f2010 9:36:40 ..,
95853 12/10f2010 9:36:40 ...
9552 12102010 %:36:40 ...
9851 12f10f2010 9:27:13 ...
9550 12f10f2010 22713 ..,

121002010 9:36:40 AM
121042010 9:36:40 AM
12/10/2010 9:36:40 AM

12/1042010 10:01:12 AM

IF Camera Mot Connected
IP Camera Mot Connected
IF Camera Mot Connected
IP Camera Mot Connected
IP Camera Mot Connected
IP Camera Mot Connected
IP Camera Mot Connected
Storage Alarm

Video Loss

Video Loss

video Loss

IF Camera Mot Connected

AWE360 - 360 JPEG 3
AWE360 - 360 JPEG 2
AWGE360 - 360 JPEG L
Input 1

CAM7321 - Eng Cubes
AYS10SDM - 5M W Windows
WY-NWS025 - 1.3M Cube
=1

Input 12

Input 11

Input 4

Aicis M3011 Linux Test

exangyision Arecont Server
exacqyision Arecont Server
exacgvision Arecont Server
exacqvision ACTi Server
exacgvision ACTI Server
exacqvision Arscont Server
exacq¥ision Panasanic Server
Dans Trunk Server

Dans Trunk Server

Dans Trunk Server

Dans Trunk Server

Dans Trunk Server

192,165,100,50
192,168.100.50
192, 165.100.50
192,168.100.23
192, 165.100.23
192,168.100.50
192.165.100.21
192.1658.100.34
192,168.,100,34
192,165,100,34
192,168, 100,34
192, 165.100.34

00-19-D1-E2-12-92
00-19-D1-E2-12-92
00-19-D1-E2-12-92
00-1C-C0-B5-6B-01
00-1C-C0-B5-66-D1
00-19-D1-E2-12-92

EROZ35001209

00-16-76-13-40-D9
00-16-76-13-4D-D9
00-16-76-13-40-D9
00-16-76-13-40-D9
00-16-75-13-4D-D9
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Options Tab

The Options tab allows you to modify eVEHM parameters and select which event types eVEHM

monitors.
The Options tab contains the following columns:

e Database. This tab allows you to configure the following options:

e Database Change Poll Interval (Seconds). This determines how often eVEHM checks the

database for events.

e Failed Database Op Retry Interval (Seconds). This determines how soon eVEHM tries to
reconnect to the database server when a connection to the server is lost.

Dakabase lEvents] Email ] Logging ]

Database change poll inkerval (seconds): |30 ﬁ

Failed database op retry interval (seconds): |1 ill

e Events. This tab allows you to choose whether to create a log entry or send an email notification

for each of the following events:

e Device Failure

e Input Trigger

e [P Camera Not Connected
e License Expiry Notices

e Motion

e Server Connection Error
e Soft Trigger

e Storage Alarm

e Temperature

e Video Loss

Dakabase Ewents lEmaiI ] Logging ]

Option Log to Database  Log ko E-mail
Device Failure v v
Input Trigger I I~
IP Carnera Mot Connected [+ I
License Expiry Matices v I
Mation I r
Server Connection Error v ™
Soft Trigaer I I
Starage &larm v I
Temperature v I~
YIdeo Loss [+ I

Purge events older than | 30 j days

evary |24 ﬁ hours,
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Select the appropriate checkboxes for each event type. You can select one logging option, both

logging options, or neither logging option for each event separately. The Events tab also allows

you to configure events older than a certain number of days and configure how often those

events are purged.

e Email. This tab allows you to configure the email notification feature. Enter the email server

address, username, password, and timeout (in seconds). Also enter the information that will be

included in the email, such as the name of the email’s sender, the email’s recipients, and the

email’s subject line. Also select the maximum number of events that can be included in a single

email and how often email notifications should be sent (in minutes).

Database ] Events Emai lLagging ]

Server Address: |

Server Username: |

Server Password: |

Server Timeout (seconds): | 60 ill

Message From: |

Message To! |

Message Subject; |

Max Events per Message: | 20 ill

Message Interval (minutes): | 60 ill

e Logging. This tab allows you to configure the maximum number of days of event information to

include in the log file, which is saved to the eVEHM server and inaccessible from the eVEHM

Client.

Database ] Events ] Email  Logging l

Mazximum Days to Log: | 30 i
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Troubleshooting

An eVEHM log file created on the server daily in \Program Files\exacqVision\Health\logs (default
location) can help you determine the cause of various issues. Following are common issues that can be
identified using the log file:

Issue: eVEHM Server does not start.

Cause: Database connection error.

Log file entry: “Failed to open DB.”

Resolution: Contact the database administrator for information about database credentials.

Issue: eVEHM Client shows no data.

Cause: eVEHM Server unable to write event data to database.

Log file entry: “Failed to update system status into DB” and “... server has gone away.”
Resolution: Contact the database administrator for information about database credentials.

The following issue can also appear in the eVEHM Client:

Issue: This message appears: “Enterprise Health Manager is not connected to this database.
Please contact your system administrator.” The title bar of the eVEHM Client also displays the
message “Enterprise Health Manager Server is not connected.”

Cause: In normal operation, the eVEHM Server increments a heartbeat counter in the database.
This message indicates the heartbeat counter is not changing.

Resolution: Contact the database administrator to determine why the eVEHM Server is not
writing to the database.
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Appendix A — MySQL Installation Procedure

If eVEHM will connect to a new MySQL database, complete these steps before starting the procedure in

the “Installation” section of this document:

1. Download the most recent version of MySQL from www.mysgl.com.

Run the MySQL installer. This might require additional software upgrades to support MySQL on

your server.

3. Onthe Choosing a Setup Type screen, select Server Only or Full. (Do not select Client Only.)

B ———— I

Choosing a Setup Type

I
MySQL. Installer

@ Developer Default
Installs all products needed for
MySQL development purposes.

Server only

Installs anly the MySQL Server
product.

Setup Type

@ Client only
Tnstalls only the MySQL Client
products, without a server,

@ Full
Installs allincluded MySQL products
and features,

© Custom
Manually select the products that
should be installed on the system.

Please select the Setup Type that suits your use case.

Setup Type Description
Installs only the My5QL Server. This type should
be used where you want to deploy a MySQL
Server, but will not be developing MySQL
applications.

Installation Path: ~
[c: Program FilesyysaL L | [:]
Data Path: =5y

[c: Programbata MySQLMYSQL Server 5.5 \[:]

< Back H Next > H Cancel

4. When prompted to select the type of configuration on the MySQL Server Configuration screen,

select Server Machine. (Do not select Developer Machine.)

L ——
i

Y\ MySQL Server Configuration
MySQL. Installer

© Server Machine

Please select the type of configuration for the MySQL Server instance.

() Developer Machine
This is a development machine, and many other applications will be
| installed on it. A minimal amount of memory will be used by MySQL.

- Several server applications will be running on this machine. Choose this
Configuration ' option for web/application servers. MySQL will have medium memory
usage.

(©) Dedicated Machine
This machine is dedicated to running the MySQL database server. No
™ other servers, such as web servers, will be run. MySQL will make use of
by all available memory.

[ [ Next> Cancel
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exacq

Technologie

Y g +1.317.845.5710
-,

y v

¥ 5 +44.1438.310163
- g

+5255.56080817

+31.485.324.347

USA (Corporate Headquarters)
Mexico

Europe/Middle East/Asia
Central Europe

Page 11 of 15
11/11/2011



5. When prompted to specify the network, Windows, and security settings on the MySQL Server
Configuration screen, take note of all the information that you enter because you will need it in

the next step and during eVEHM installation.

MySQL Server Configuration

Please specify the Network, Windows, and Security settings

[V Enable TCP/IP Networking

== Port Number: 3306

V] Create Windows Service

Windows Service Name: exacqEVHM_1
Configuration
Security Settings

2

MySQL Root Password:

Repeat Password:

to store

<Back H Next >

)|

Cancel

l

6. After the MySQL installation is complete, create the eVEHM database in MySQL. To do this,

complete the following steps:

a. Start the MySQL command line application.
Enter “create database xxxxx,” where “xxxxx” is the Windows service name created in

step 5.

c. Type “exit” and press Enter to close the command line application.

MySQL 5.5 Command Line Clie

[Enter password:

Wlelcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is

Server version: 5.5.15 MySQL Community Server (GPL)>

Copyright (c) 2008, 2010, Oracle and/or its affiliates. All rights reserved.

Oracle registered trademark of Oracle Corporation and/or its

affilia Other names may bhe trademarks of their respective
ouners.

Type “help;’ or ’\h’ for help. Type ’\c’ to clear the current input statement.

mysgql> create database exacgqEUHM_1;
Query OK, 1 row affected (B.88 sec>

mysgl> _

e)‘acq WWW.exacg.com
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7. By default, Windows Firewall blocks database access to remote users. Either disable Windows
Firewall, or configure an exception for the SQL port.

+® Windows Firewall with Advanced Security

File Acton View Help

L LAEE

&3 Inbound Rules
&Y Outbound Rules

B, Monitoring

ws Firewall with Advanced 3§ Windows Firewall with Advanced Security on Local Computer

A 1
:'._ Connection Security Rules # Windows Firewall with Advanced Security provides networl security for Windows compute

Overview

Domain Profile

B Windows Firewall is off.
Private Profile

kd Windows Firewall is off.

Public Profile is Active

& Windows Firewall is off.

B Windows Firewall Properties

8. By default, MySQL does not grant user access to remote clients. Add each user account to
MySQL as follows:
a. Start the MySQL command line application.
b. Enter the following:

grant all privileges on [dbname].* to [user]@’[IP address] identified by ‘[Password]’;

[dbname] is the database name created in step 5.

[user] is either the database username created in step 5, or the first of each
username to be created.

[IP address] is the IP address of the user. If multiple IP addresses are possible
(such as with DHCP), use the % wildcard symbol as shown here:

lySQL 5.5 Command Line Client

Enter password:

lWelcome to the MySQL monitor. Commands end with ; or “g.
Your MySQL connection id is

Server version: 5.5.15 MySQL Community Server (GPL>

Copyright C(c> 2088, 2018, Oracle and-sor its affiliates. All rights reserved.
Oracle is a registered trademark of Oracle Corporation andsor its
affiliates. Other names may bhe trademarks of their respective

OWNErs .

Type *help;* or “~h' for help. Type *“c’' to clear the current input statement.

myzgl> grant all privileges on exacqEUHM.* to user@'192_168.%* identified by ’'REallyStrBngPASSworD’ ;
Query OK. B rows affected (B.68 sec)

mysgl>

[Password] is the database password of the [user] account.

NOTE: The special characters (dot-asterisk, apostrophes, and semicolon) are all required. If
a “Query OK” message is not received after pressing Enter, the privilege was not added.

9. Continue with the procedure in the “Installation” chapter of this document.
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Appendix B — Installation Notes

Creating a DSN. In a Windows deployment where the database backend will be SQL server, the database
connection will be via ODBC. Before installing either the Client or the Server on a computer, a data
source name (DSN) must be created. This DSN is used to inform both eVEHM Server
(evHealthServer.exe) and eVEHM Client (evClientServer.exe) where to find the database. Creating a DSN
is done via Start->Settings->Control Panel->Administrative Tools->Data Sources (ODBC). If this computer
will run the eVEHM Server, ensure that the DSN created is a System DSN, not a User DSN. This is
selected on the first tab of the ODBC Data Source Administrator dialog.

Service Control Manager. The Windows eVEHM Server installer registers evHealthServer as a service. It
sets the recovery operations to retry the service first and then reboot the system upon service failure.
These recovery options can be edited using Windows Service Control Manager (Start->Run-
>services.msc). There is no dependency set against the SQL Server because it is possible that the SQL
Server will be running on a different computer. Upon startup, the eVEHM Server will continue trying to
connect to the SQL Server periodically until it successful.

eVEHM Client Database Permissions. The eVEHM Client user must have database credentials giving
permission for certain operations:

For true read only access to the data,
SELECT ON [healthdbname].*

For the ability to acknowledge alarms
SELECT, INSERT, UPDATE, DELETE ON [healthdbname].EVH_Acks

For the ability to add/remove systems
SELECT, INSERT, UPDATE, DELETE ON [healthdbname].EVH_Systems

For the ability to change settings
SELECT, INSERT, UPDATE, DELETE ON [healthdbname].EVH_Options

If a user without sufficient permissions attempts an operation, a message box will be displayed
containing the SQL error from the database.

Server Database Configuration. The eVEHM Server always reads evHealthServer.ini from its current
directory. If the INI file is missing or invalid, the service defaults to a SQLite database evHealth.db in its
immediate directory. The INI file is expected to contain the following:

e Group "[DatabasePrefs]".

e Required property "Engine" is "SQLite", "ODBC", or "MySQL".

e Required property "Name" is the relative/full path to a SQLite database file, an OBDC DSN, or a
MySQL schema name.

e Property "Username" is ignored by SQLite, optional for ODBC, and required for MySQL.

e Property "Password" is ignored by SQlite, optional for ODBC, and required for MySQL.

e Property "Hostname" is ignored by SQLite and ODBC, and required for MySQL.
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e Property "Port" is ignored by SQLite and ODBC and optional for MySQL (the default MySQL port
3306 is hard-coded in the service).

Client Database Configuration. The eVEHM Client must use the same database as the eVEHM Server.
The Client is pointed to that database in the following order:

e Command Line parameters:

o /I, --ini=<str> INI file to use, defaults to “evHealthServer.ini”
o /s, --sqlite=<str> sqlite database to open, defaults to “evHealth.db”
o /m, --mysql=<str> mysql database to open, defaults to “evHealth”
o /o, --odbc=<str> odbc database to open, defaults to “evHealth”
o /u, --username=<str> username for database connection (not used for SQLite)
o /p, --password=<str> password for database connection (not used for SQLite)
o /a, --address=<str> mysql host address or name (not used for SQLite or ODBC)
o /[t --port=<str> mysql host port or name (not used for SQLite or ODBC)
e evHealthServer.ini in the current directory with the same format specified for the eVEHM
Server.

e Windows Registry entries in HKEY_CURRENT_USER\Software\evHealthClient. In Linux or MacOS,
the /Conf or /Pref files are used.

e An SQlite database called evHealth.db in the current directory.

e Open blank and force the user to 'File | Open'.

Server Command Line Parameters. The Windows Server installer will invoke evHealthServer as
appropriate to register the eVEHM Server as a service and update database schema as necessary. A
Linux eVEHM Server installation must perform these operations manually.

e evHealthServer /registerService /displayName="exacqVision Health Service" -- (Windows)
Service recovery options are configured and sets the description.

e evHealthServer /unregisterService -- (Windows) Unregister service and exit.

e evHealthServer --daemon --pidfile=/var/run/whateveryouwant.pid -- (Linux) Run as daemon.

e evHealthServer /updatedb (Windows), evHealthServer —updatedb -- (Linux) The database is
validated at startup, and any necessary changes are attempted. If any change fails (for example,
if the database user doesn't have change permissions), regardless of whether the field is
*required® or *optional*, an error code (non-zero) is returned, and a short error message is
returned on stdout. Otherwise, a success code (zero) is returned.

e evHealthServer /writeschema=FILENAME (Windows), evHealthServer --writeschema=FILENAME
-- (Linux) The database is validated at startup, and the SQL statements for any necessary changes
are written to the specified file.
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